Application Error - UserList

Topics: General
Sep 23, 2014 at 6:12 PM
Edited Sep 23, 2014 at 6:30 PM
I copied User data from one environment to another (test to production) and I an now getting an error when trying to do Admin->User Accounts.

Application Error - /DssIssues/Administration/Users/UserList


What table might I have mucked up to cause this? I coped to Users, BugNet_UserProfiles, BugNet_UserProjects, BugNet_UserRoles and Memberships.

Thanks!

Also realized that same thing happens when doing Admin->Projects->select project

Application Error - /DssIssues/Administration/Projects/EditProject/1
Sep 23, 2014 at 7:26 PM
I can see all users in a drop down user list just fine, btw.
Sep 23, 2014 at 10:28 PM
If there is no way to fix this problem, can I export the user data I have, clear out the user table, and import them back into the database? If this is a route I can take, what are all the tables I need to touch? Can I import the userids, or are they generated, and if so how?

Thanks, as always, for all the help.
Sep 24, 2014 at 2:09 AM
asudman wrote:
If there is no way to fix this problem, can I export the user data I have, clear out the user table, and import them back into the database? If this is a route I can take, what are all the tables I need to touch? Can I import the userids, or are they generated, and if so how?

Thanks, as always, for all the help.
Can you get the actual error, check the log viewer or set customErrors mode="Off" in the web.config to see the full error message.
Marked as answer by asudman on 9/24/2014 at 6:28 AM
Sep 24, 2014 at 2:28 PM
Thanks! That helped fix it. Had a username that was in the user table twice. Guess I have some more work to do on my syncing ;-)