Trying to turn off Windows SAM authentication and getting 401.2 error

Topics: General
Jul 25, 2014 at 5:18 PM
Edited Jul 29, 2014 at 4:04 PM
I changed the authentication source to 'none' in BugNet and commented out the AuthenticationModule references in the web.config, but when I try to access the site I'm getting a 401.2 error. What am I missing? My BugNet website has anonymous and forms authentication enabled and windows authentication disabled. Should I be using Basic??

Jul 30, 2014 at 8:52 PM
I think you still need windows authentication enabled when you enable anonymous authentication.
Aug 5, 2014 at 5:38 PM
Ok...tried to disable anonymous authentication and when I try to login, I get the dreaded 401.2 error. At this point I only have Forms Authentication enabled in IIS. In BugNet I have user account source = None, user registration = verified, anonymous access = disable.

If I enable anonymous in IIS, everything seems to work fine. Should I just do that and leave it alone? Just trying to understand/figure out what is going on here.
Aug 5, 2014 at 5:52 PM
Yes, you will need anonymous on for forms authentication as well, otherwise no one would be able to access the site.

The only time you turn anonymous off is for explicit windows authentication which then takes the users local logged on account and passes it to BugNET.
Aug 6, 2014 at 5:31 PM
hopefully last thing on this. I have anonymous one, forms auth on, windows auth off, and I'm being asked for my windows logon in a "popup" window when I try to access bugnet, once I key in my windows logon it goes to the normal login screen, with my windows credentials showing in the upper right corner. Why is it prompting for the windows credentials, and how do I make it stop (if I can).
Aug 6, 2014 at 6:00 PM
I have seen this happen if you are using a virtual directory outside of the default wwwroot IIS folder structure and the directory doesn't have the same permissions. Something to check.
Aug 7, 2014 at 1:28 PM
Nope, that is not it. Directory is under the default IIS folder and permissions are set for network service (windows 7). Anything else I can try?
Aug 7, 2014 at 2:02 PM
Create a second virtual directory, ensure that works and compare the settings.
Aug 7, 2014 at 2:18 PM
odd...the new one worked just fine but I couldn't see anything different with the authorization settings. just ended up deleting the old virtual directory and recreating all seems to be fine!

thanks for the tip!
Aug 7, 2014 at 4:11 PM
No problem.