How to configure CKEditor toolbar?

Topics: Customizing BugNET
Aug 3, 2012 at 5:51 AM

Hi,

After updating to 0.9.161.0 the toolbar of CKEditor (showing when you are leaving comment to issue) has been modified to like this:

 

Before installing the new bugnet version  there were more buttons in this toolbar (like font size, colour etc.) and users want to use those still.

Is there a configuration for this toolbar somewhere?

Thanks,

-Juho

Developer
Aug 7, 2012 at 12:16 AM

See http://docs.cksource.com/CKEditor_3.x/Developers_Guide/Toolbar on how to customize the toolbar and or create your own.

If you create your own you can set it in the web.config HtmlEditorProvider section by changing the CkHtmlEditorProvider element Toolbar attribute.

Coordinator
Aug 7, 2012 at 1:37 PM
Edited Aug 7, 2012 at 1:38 PM

I have added this to the customize documentation page for future reference - http://bugnet.codeplex.com/wikipage?title=Customize&referringTitle=Documentation

Jan 10, 2013 at 7:21 PM

I like to activate buttons like Font in the editor.
From the documentation I cannot figure how to do that.

I've seen the setting Toolbar="Basic", but I did not find any file in the bugnet folder tree where this Basic-Toolbar is defined.
Are there other built in toolbars I can activate? For example Toolbar="Full" or similar?

Where is the "Basic" toolbar defined?

alex.

 

Dec 2, 2014 at 7:02 AM
Hi i just upgraded to version 1.6.329.0
i change the toolbar setting in Web.Config and even removed the toolbar (i think the default is full)
<add name="CkHtmlEditorProvider" type="BugNET.Providers.HtmlEditorProviders.CkHtmlEditorProvider, BugNET.Providers.CkHtmlEditorProvider" Height="250" Width="100%" providerPath="~\Scripts\CKEditor\" />
but nothing happened.i recycled the pool and ctrl+f5 no change!
i defined my toolbar in config.js and set the toolbar to it but it had no effect.
is there anything i m missing?
Dec 2, 2014 at 7:13 AM
Hi Mojtaabaa,

I had the same problem.
The following steps solved them for me:

1) Replace included CKEditor with full version from: http://ckeditor.com/download
2) add/replace the following line in web.config
<add name="CkHtmlEditorProvider" type="BugNET.Providers.HtmlEditorProviders.CkHtmlEditorProvider, BugNET.Providers.CkHtmlEditorProvider" Height="250" Width="100%" Toolbar="Full" providerPath="~\Scripts\CKEditor\" />

alex.
Dec 3, 2014 at 5:17 AM
alex_enjoy wrote:
Hi Mojtaabaa,

I had the same problem.
The following steps solved them for me:

1) Replace included CKEditor with full version from: http://ckeditor.com/download
2) add/replace the following line in web.config
<add name="CkHtmlEditorProvider" type="BugNET.Providers.HtmlEditorProviders.CkHtmlEditorProvider, BugNET.Providers.CkHtmlEditorProvider" Height="250" Width="100%" Toolbar="Full" providerPath="~\Scripts\CKEditor\" />

alex.
Dear Alex
thanks for the reply.it solved my problem.
Best Regards