Nothing To Install At This Time Error

Topics: Installing BugNET
Jul 13, 2012 at 7:29 AM
Edited Jul 13, 2012 at 7:30 AM

Hello guys,

I am trying to Install BugNET on my PC. I got SQL server 2008 and all other things necessary to run BugNET suddenly this error appeared.

Nothing To Install At This Time

Current Database Version: ERROR Cannot open database "BugNET" requested by the login. The login failed. Login failed for user 'IIS APPPOOL\ASP.NET v4.0'.

Current Assembly Version: 0.9.161.0

No Upgrade needed.

Need your help guys. :) Than you so much for your future help.

Otep
IT Enthusiast 

 

Jul 19, 2012 at 3:01 PM

I tried to install BN using both integrated security & sql user security.  When I tried via integrated security, I get the same error as jctorrente.  When I tried with sql user security, I get a bunch of error with running sql statements.

FYI...I am trying to run with my Win 7 Pro PC and SQL Express 2012.  My Sql Express is set up to allow remote connections and both TCP/IP & Named Pipes protocols have been enabled.

Jul 19, 2012 at 6:42 PM

jctorrente, i think i figured out.  if you assigned permissions to "NETWORK SERVICE" account, then try changing your "ASP.NET v4.0" application pool's identity from "ApplicationPoolIdentity" to "NETWORK SERVICE".

Jul 19, 2012 at 9:49 PM

I have the same problem and I did what jinnjuice suggested but I still get error "Nothing to install At this Time" Cannott open database "BugNet" I'm currently using SQL Express 2008. If anyone can help I would really appreciate it.

 

thank you.

Jul 19, 2012 at 11:38 PM

I figured it out.  

 

 I had to download the SQL Management Studio and install it on the same box that my SQL Express 2008 was installed. Then I created a Database called it Bugnet and gave the Network Service account dbo_owner to the Bugnet database. After I did that I was able to install Bugnet and now its up and running.

Oct 19, 2012 at 2:18 PM

I could resolve the issue by giving the role members starting with aspnet_xxxxx for NETWORK SERVICE user role in SQL Management Studio.

Sep 18, 2014 at 8:25 PM
jinnjuice solution from Jul 19, 2012 at 1:42 PM worked for me!
jctorrente, i think i figured out. if you assigned permissions to "NETWORK SERVICE" account, then try changing your "ASP.NET v4.0" application pool's identity from "ApplicationPoolIdentity" to "NETWORK SERVICE".
Here's my setup and a re-explanation:

BugNet v1.5.265
Win O/S Server 2008 R2
SQL 2008
dB Name = BugNet, and the "NETWORK SERVICE" account is set as the db_owner (in Properties > User Mapping)
    <connectionStrings>
        <clear/>
        <add name="BugNET" connectionString="server=.\SQLExpress;database=BugNet;Trusted_Connection=True;uid={username};pwd={password}" providerName="System.Data.SqlClient" /> 
    </connectionStrings>
For IIS 7.5:
  1. click Applications Pools
  2. highlight ASP.NET v4.0
  3. click Advanced Settings... from Actions pane on the right
  4. Under Process Model section, edit the Identity property
  5. Change the Built-in account to "NetwrokService" (instead of "ApplicationsPoolIdentity")