Upgrading an old build (BugNET 0.8.304)

Topics: General, Installing BugNET
Jan 7, 2014 at 4:15 PM
I have an old build (BugNET 0.8.304) installed on an old creaking 'Server 2003' and wish now have a newer and more powerful 'Server 2008'. The old build contains several hundred bugs I am tracking.

I wish to upgrade to latest version of BugNet (1.5.265) however I hit a rather big problem - they seem to be completely incompatible.

I have tried restoring the database, but the new version complains there are columns missing (obviously expected).

Can anyone help?
Jan 7, 2014 at 4:48 PM
Edited Jan 7, 2014 at 4:48 PM
Hi,

Each new version has scripted updates and you should be able to upgrade from that version to the latest but you may encounter some issues from such an old version.

The best thing to do is backup everything (database and web application directory) then follow the upgrade directions, if you encounter an error when the scripts are run, make note and report back here and we can help guide you on where to look for the issue.

Typically the issues from such older versions are orphaned rows in the database due to the lack of referential integrity in older versions. These are usually cleaned up during the upgrade but it may not catch everything and need some manual intervention.
Jan 8, 2014 at 12:27 PM
Thanks for the response.

I can confirm I have followed the upgrade instructions.

I now have BugNet 1.5.265.0 installed, however I am still experiencing issues so hope someone can advise.

During the upgrade, I was informed by the script that everything was successful. Looking through the database, the data has been copied across (for example, in dbo.BugNet_UserProfiles I can see my profile and in dbo.BugNet_Issues I can see hundreds of issues that were logged in the previous build on my old server.

The problem is that I am unable to log-in using my credentials (I am 99% sure these are correct) and also believe that even when not logged in, you should be able to see the bug list (not 100% sure this was the case). Strangely enough, BugNet is pulling some data successfully as my custom welcome message is displayed from the HostSettings/WelcomeMessage column.

I have tried sending a password reminder, which states it has been sent but I am not receiving anything (tried multiple accounts). To ensure that the right SMTP settings are specified in the HostSettings table, I created a simple console app to test them and can confirm these are correct also.

Any thoughts on how to progress?

Many thanks


Jan 8, 2014 at 2:35 PM
Edited Jan 8, 2014 at 2:35 PM
The password not working is expected as we moved from encrypted to hashed passwords in the newer version and you require to do the password reset.

The password reset email will be sent to the users email address, you can double check in the database that the email address is correct, and also check that the account is not locked out. (although you should see a message about that in the UI when doing a password reset).

You may have checked this too but make sure those password reset emails are not being sent to your spam folder.
Jan 8, 2014 at 2:43 PM
Thanks, I'll check this now.

Could you please advise where the email address are stored?

Also, do you have a hashed/unhashed password that I could try?

Thanks


Jan 8, 2014 at 2:55 PM
Usernames are stored in the Users table, then the email address is in the Memberships table.
Jan 8, 2014 at 4:02 PM
From: dubeaud
Usernames are stored in the Users table, then the email address is in the Memberships table.
Read the full discussion online.
To add a post to this discussion, reply to this email ([email removed])
To start a new discussion for this project, email [email removed]
You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.
Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com
Jan 13, 2014 at 8:31 PM
Did you make any further progress on this?
Jan 13, 2014 at 8:46 PM
Hi,

I think I found a solution, but won't be in until tomorrow. Will update then.

Thanks


Jan 14, 2014 at 9:45 AM
I can confirm this is now resolved.

I had to reset the password for the admin account.

Many thanks for your assistance


Jan 15, 2014 at 4:05 PM
Good to hear. You are welcome.
Feb 25, 2014 at 1:33 PM
I am still unable to fix that problem .. kindly help