Launch Error: <ajaxToolkit:ToolkitScriptManager... Parser Error

Topics: Installing BugNET
May 7, 2013 at 2:59 PM
Edited May 8, 2013 at 2:44 PM
After success installing (with link http://localhost/BugNET/Install/Install.aspx) try to start project
(with link (with link http://localhost/BugNET/default.aspx)
and I get the error:

Parser Error
Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

Parser Error Message: Unknown server tag 'ajaxToolkit:ToolkitScriptManager'.

Source Error:
Line 15: <div id="container">
Line 16: <form id="form1" runat="server" enctype="multipart/form-data">
Line 17: <ajaxToolkit:ToolkitScriptManager ID="ScriptManager1" runat="server" EnableScriptGlobalization="true"
Line 18: EnableScriptLocalization="true" EnablePartialRendering="true" EnablePageMethods="true">
Line 19:             <Services>
Source File: /BugNET/Shared/Site.Master Line: 17
Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.1
Coordinator
May 7, 2013 at 4:38 PM
Chaki_Black wrote:
After success installing (with link http://localhost/BugNET/Install/Install.aspx) try to start project
(with link http://localhost/BugNET/Install/Install.aspx)
and I get the error:

Parser Error
Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

Parser Error Message: Unknown server tag 'ajaxToolkit:ToolkitScriptManager'.

Source Error:
Line 15: <div id="container">
Line 16: <form id="form1" runat="server" enctype="multipart/form-data">
Line 17: <ajaxToolkit:ToolkitScriptManager ID="ScriptManager1" runat="server" EnableScriptGlobalization="true"
Line 18: EnableScriptLocalization="true" EnablePartialRendering="true" EnablePageMethods="true">
Line 19:             <Services>
Source File: /BugNET/Shared/Site.Master Line: 17
Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.1
Verify you have the following in the web.config (default BugNET web.config)
<pages enableSessionState="true" theme="Default" clientIDMode="AutoID">
            <controls>
                <add assembly="AjaxControlToolkit" namespace="AjaxControlToolkit" tagPrefix="ajaxToolkit"/>
          
May 7, 2013 at 6:51 PM
Edited May 7, 2013 at 6:52 PM
No, I didn't have this parameter in web.config, but I googled erlier and set this line.
In this case I have another error:

Parser Error
Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

Parser Error Message: Could not load file or assembly 'AjaxControlToolkit, Version=4.1.60919.0, Culture=neutral, PublicKeyToken=28f01b0e84b6d53e' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

Source Error:
Line 1:  <%@ Master Language="C#" AutoEventWireup="true" CodeBehind="Site.master.cs" Inherits="BugNET.Shared.Site" %>
Line 2:  
Line 3:  <%@ Register Src="~/UserControls/Banner.ascx" TagName="Banner" TagPrefix="bn" %>
Source File: /BugNET/Shared/Site.Master Line: 1
Assembly Load Trace: The following information can be helpful to determine why the assembly 'AjaxControlToolkit, Version=4.1.60919.0, Culture=neutral, PublicKeyToken=28f01b0e84b6d53e' could not be loaded.

=== Pre-bind state information ===
LOG: User = IIS APPPOOL\ASP.NET v4.0
LOG: DisplayName = AjaxControlToolkit, Version=4.1.60919.0, Culture=neutral, PublicKeyToken=28f01b0e84b6d53e
 (Fully-specified)
LOG: Appbase = file:///C:/inetpub/wwwroot/BugNET/
LOG: Initial PrivatePath = C:\inetpub\wwwroot\BugNET\bin
Calling assembly : BugNET, Version=1.3.242.0, Culture=neutral, PublicKeyToken=null.
===
LOG: This bind starts in default load context.
LOG: Using application configuration file: C:\inetpub\wwwroot\BugNET\web.config
LOG: Using host configuration file: C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet.config
LOG: Using machine configuration file from C:\Windows\Microsoft.NET\Framework64\v4.0.30319\config\machine.config.
LOG: Post-policy reference: AjaxControlToolkit, Version=4.1.60919.0, Culture=neutral, PublicKeyToken=28f01b0e84b6d53e
LOG: Attempting download of new URL file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/Temporary ASP.NET Files/bugnet/e70c84d3/5b9ce869/AjaxControlToolkit.DLL.
LOG: Attempting download of new URL file:///C:/Windows/Microsoft.NET/Framework64/v4.0.30319/Temporary ASP.NET Files/bugnet/e70c84d3/5b9ce869/AjaxControlToolkit/AjaxControlToolkit.DLL.
LOG: Attempting download of new URL file:///C:/inetpub/wwwroot/BugNET/bin/AjaxControlToolkit.DLL.
WRN: Comparing the assembly name resulted in the mismatch: Revision Number
ERR: Failed to complete setup of assembly (hr = 0x80131040). Probing terminated.
Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.1
Coordinator
May 8, 2013 at 2:33 PM
Which package are you trying to install? It shouldn't be necessary to fiddle with the web.config in this regard or missing the ajax toolkit assemblies.
May 8, 2013 at 2:43 PM
Edited May 8, 2013 at 2:45 PM
I'm stying to install from Web Deployment Package.
There were several other problems, it didn't wanted to be installed with build-in login of SQL Server 2008 R2 Express. After a few manipulations I've installed it (I had an message that system was installed successfully).
When I'm trying to lunch main page with http://localhost/BugNET/default.aspx - nothing. I have a error like at previous post.
I'm using:
  • Windows Server 2008 R2 x64 Enterprise (with IIS 7.5);
  • Microsoft Framework 4.0 (ASP.NET 4.0 too);
  • Microsoft SQL Server 2008 R2 RTM Express.
    Very strange. Maybe I'm doing something wrong, but as instruction says...
    P.S. Maybe it doesn't want to work with x64 platform?
May 31, 2013 at 9:11 AM
Did the same actions on Windows 7 Ultimate x86 - works from the first time.