Don't know what I'm doing wrong

Topics: Installing BugNET
Nov 5, 2012 at 4:17 AM

Server 2008 R2 64 bit - SQL Express 2005 (from/for Backup Exec but I can use it for another instance, right?)

BugNet 1.1

I have tried the install several times.  When I go to http://localhost/BugNet/Install/Install.aspx

I get (I enabled the debug errors) - do I need to add the Network Service account to SQL (which means installing SQL Express Manangement Studio, I guess)?  Thanks....

 

Server Error in '/' Application.

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level.  This error can be caused by a virtual directory not being configured as an application in IIS.

Source Error:

Line 9:          <reporting enabled="false"/>
Line 10:     </dotNetOpenAuth>
Line 11:     <DataProvider defaultProvider="SqlDataProvider">
Line 12:         <providers>
Line 13:             <add name="SqlDataProvider" type="BugNET.Providers.DataProviders.SqlDataProvider, BugNET.Providers.SqlDataProvider" connectionStringName="BugNET" providerPath="~\Providers\DataProviders\SqlDataProvider\"/>


Source File: C:\inetpub\wwwroot\bugnet\web.config    Line: 11

 

 

 

 

 

Nov 5, 2012 at 3:37 PM
Edited Nov 5, 2012 at 3:42 PM

OK, I paid attention to the line about the application and did that step again (I have gone through this several times from the beginning.)  Now I'm getting this even though I have added the Network Service to the folder (in fact, I added it to the whole BugNet Folder just to troubleshoot and that didn't help.)

 

BugNET Configuration Error

Access to the path 'C:\inetpub\wwwroot\bugnet\Config\Backup_201220050920\' is denied.

BugNET has file upload capabilities for attachments. These features require custom security settings so that the application is able to create and remove files in your website.

Using Windows Explorer, browse to the root folder of the website ( C:\BugNET by default ). Right-click the folder and select Sharing and Security from the popup menu ( please note that if you are using Windows XP you may need to Enable Simple File Sharing before these options are displayed ). Select the Security tab. Add the appropriate User Account and set the Permissions.

If using Windows 2000 - IIS5
- the {Server}\ASPNET User Account must have Read, Write, and Change Control of the virtual root of your website

If using Windows 2003 - IIS6
- the NT AUTHORITY\NETWORK SERVICE User Account must have Read, Write, and Change Control of the virtual root of your website

 

Coordinator
Nov 5, 2012 at 3:45 PM

If your IIS app pool is running under a different user, then that user needs write permission to the folder.

Nov 5, 2012 at 4:51 PM
dubeaud wrote:

If your IIS app pool is running under a different user, then that user needs write permission to the folder.


Thank you!  That helped.  Now it is erroring with this below.  I dropped the firewall and remote connections were already allowed so I guess that means the Server/Instance needs to be specified?  Like I said, this machine has Backup Exec on it - don't know if that matters.  Looks like the instance name is \BKUPEXEC  Maybe I should create a VM instead.

 

Version: 1.1.213.0

Installation Status Report

00:00:00 - Installing Version: 1.1.213.0
00:00:00 - Installing Membership Provider:
00:00:00 -    Executing Script: InstallCommon.sql Error!

Error Details

File InstallCommon.sql
Error   A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified)