Application Error - IssueDetail.aspx

Topics: General
Oct 23, 2012 at 6:53 PM

Hi, I just installed Bugnet, but when i try to go to details it gives me the following error:

 

Application Error - /bugnet/Issues/IssueDetail.aspx

An error has occured in processing your request.

Please try again.

 

The bugnet logs wont give no error.

 

OS Windows Server 2012 IIS8 MSSQL 2012.

 

 

Thanks for the help.

Developer
Oct 23, 2012 at 7:13 PM

Only the details page throws the error?  The rest of the site works fine?

Oct 24, 2012 at 10:52 AM
wrhighfield wrote:

Only the details page throws the error?  The rest of the site works fine?

Ys, the rest of the site works well.
Very strange, i would like to make it work but my knowladge in the area ( .net ) its limited, im a sys admin, not a coder.

 

 

 

Coordinator
Oct 24, 2012 at 2:18 PM

Hi,

  1. Open the web.config file in notepad or another text editor 
  2. Find the customErrors tag
  3. set it to the following:

<customErrors mode="Off"/>

Once this is done and you have saved the file, go to the issue detail page that you were having issues with earlier. You should be presented with the "real" error and you can post back with more details at that point.

Thanks.

Oct 24, 2012 at 2:54 PM
dubeaud wrote:

Hi,

  1. Open the web.config file in notepad or another text editor 
  2. Find the customErrors tag
  3. set it to the following:

 

<customErrors mode="Off"/>

 

Once this is done and you have saved the file, go to the issue detail page that you were having issues with earlier. You should be presented with the "real" error and you can post back with more details at that point.

Thanks.

Ok,

 

It give the following error:

 

Server Error in '/bugnet' Application.

Data is Null. This method or property cannot be called on Null values.

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

Exception Details: System.Data.SqlTypes.SqlNullValueException: Data is Null. This method or property cannot be called on Null values.

Source Error: 

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.


Stack Trace: 

[SqlNullValueException: Data is Null. This method or property cannot be called on Null values.]
   System.Data.SqlClient.SqlBuffer.get_String() +6638970
   BugNET.Providers.DataProviders.SqlDataProvider.GenerateIssueNotificationListFromReader(IDataReader returnData, List`1& issueNotificationList) +295
   BugNET.Providers.DataProviders.SqlDataProvider.ExecuteReaderCmd(SqlCommand sqlCmd, GenerateListFromReader`1 gcfr, List`1& list) +179
   BugNET.Providers.DataProviders.SqlDataProvider.GetIssueNotificationsByIssueId(Int32 issueId) +336
   BugNET.Issues.UserControls.IssueTabs.GetTabName(String tabName, String tabValue) +847
   BugNET.Issues.UserControls.IssueTabs.RefreshTabNames() +322
   System.Web.UI.Control.PreRenderRecursiveInternal() +113
   System.Web.UI.Control.PreRenderRecursiveInternal() +222
   System.Web.UI.Control.PreRenderRecursiveInternal() +222
   System.Web.UI.Control.PreRenderRecursiveInternal() +222
   System.Web.UI.Control.PreRenderRecursiveInternal() +222
   System.Web.UI.Control.PreRenderRecursiveInternal() +222
   System.Web.UI.Control.PreRenderRecursiveInternal() +222
   System.Web.UI.Control.PreRenderRecursiveInternal() +222
   System.Web.UI.Control.PreRenderRecursiveInternal() +222
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +4297

Developer
Oct 25, 2012 at 3:17 AM

Can you run this query against your bugnet database and see if it comes back with either zero or an actual count?

select COUNT(*) from aspnet_Membership where Email is null

Thanks,
William

Oct 25, 2012 at 1:44 PM

Hit ig gives a column with a cell both with value 1.

 

thanks for the help.

Developer
Oct 25, 2012 at 5:00 PM

This is a (possible) issue with your data it seems that you have a user that has no email address, can you check your users in BugNET and see if one does not?  If not can you give it one (even a fake one) and see if you still get an error?

Also can you remember being able to create a user with no email address?

Thanks
William

Oct 27, 2012 at 5:53 PM
wrhighfield wrote:

This is a (possible) issue with your data it seems that you have a user that has no email address, can you check your users in BugNET and see if one does not?  If not can you give it one (even a fake one) and see if you still get an error?

Also can you remember being able to create a user with no email address?

Thanks
William

You are right on the money!!!

My account had no email associated, and all users that access the issues that i created it gave tha error.

 

I installed the Bugnet, and then changed to Active directory, my account was the first.

 

Dont have a clue why my account had no email, all others from AD had their email.

 

Thanks for all the help :)

Sincerely,

Alexandre Monteiro