Upgrade from 0.8.?.?

Topics: Installing BugNET
Jul 31, 2012 at 12:23 PM

Hi

I downloaded the new version copied it over the existing version. Checked that the web.config is correct. Changed the DotNet version to 4 in the app pool. Created the empty "App_Offline.html" file and started a browser pointed to the website.

I received the error below

An error occurred creating the configuration section handler for DataProvider: Could not load type 'BugNET.DataAccessLayer.DataProviderConfiguration' from assembly 'BugNET'.

Coordinator
Jul 31, 2012 at 2:20 PM
Edited Jul 31, 2012 at 2:21 PM

Hi,

There were a few additions to the web.config and you may have missed one or it looks like the type name is incorrect.  See the bolded section below. (from the release.config in the repository / web.config in the release package)

<configSections> <section name="dotNetOpenAuth" type="DotNetOpenAuth.Configuration.DotNetOpenAuthSection" requirePermission="false" allowLocation="true"/> <section name="HtmlEditorProvider" type="BugNET.Providers.HtmlEditorProviders.HtmlEditorConfiguration, BugNET.Providers.HtmlEditorProviders" requirePermission="false" allowDefinition="MachineToApplication"/> <section name="DataProvider" type="BugNET.DAL.DataProviderConfiguration, BugNET.DAL" requirePermission="false" allowDefinition="MachineToApplication"/> </configSections>

Cheers.

Jul 31, 2012 at 9:51 PM

Excellent

Thanks for your help.

Shows how we look at things and see only what we want to see.

Regards

Gordon

From: dubeaud [email removed]
Sent: 31 July 2012 15:21
To: gordon@vcs.co.za
Subject: Re: Upgrade from 0.8.?.? [bugnet:389690]

From: dubeaud

Hi,

There were a few additions to the web.config and you may have missed one or it looks like the type name is incorrect. See the bolded section below. (from the release.config in the repository / web.config in the release package)

<configSections>
        <section name="dotNetOpenAuth" type="DotNetOpenAuth.Configuration.DotNetOpenAuthSection" requirePermission="false" allowLocation="true"/>
        <section name="HtmlEditorProvider" type="BugNET.Providers.HtmlEditorProviders.HtmlEditorConfiguration, BugNET.Providers.HtmlEditorProviders" requirePermission="false" allowDefinition="MachineToApplication"/>
        <section name="DataProvider" type="BugNET.DAL.DataProviderConfiguration, BugNET.DAL" requirePermission="false" allowDefinition="MachineToApplication"/>
 </configSections>
 
 
 

Cheers.