Bugnet Configuration error during install

Topics: Installing BugNET
May 29, 2012 at 10:16 PM

Hi,

I am trying to install Bugnet 0.9.161 on a system that has -

IIS 5.1

Windows Xp

I am getting following configuration error when trying to get to http://localhost/BugNet/Install/Install.aspx -

"An error occurred loading a configuration file: Failed to start monitoring changes to 'c:\inetpub\wwwroot\bugnet\install\web.config' because access is denied."

I dont see any web.config file inside the install folder. Also, I have given following accounts full rights to the bugnet folder -

1. Network service account

2. ASP.NET machine account

Please help me in figuring out the issue. Thank you for your help.

Coordinator
May 30, 2012 at 4:14 PM

I would unzip the installation file again.  There should definitely be a web.config file in the package and you only need to give the asp.net machine account access in your case since you are running on XP.

May 30, 2012 at 4:17 PM

Hi,

There is a web.config file inside the bugnet folder but there is none inside the install folder. Should there be one inside install folder as well?

May 31, 2012 at 6:32 PM

I have still not been able to resolve this issue. As you see the error message, application is trying to access c:\inetpub\wwwroot\bugnet\install\web.config which is not present. There is no web.config file in the "install" folder. Please let me know what I am missing here. Thanks.

Developer
May 31, 2012 at 7:14 PM

It's hard to help when we really don't know what you have done (with regards to the steps) you have take up to this point.

My gut feeling is that it might be one of two issues

  1. The settings in IIS for the Bugnet is not running as an Application
  2. The wrong ASP.NET version is selected the for the Application

If you have followed the instructions here : http://bugnet.codeplex.com/wikipage?title=Installing%20BugNET&referringTitle=Documentation then this is for IIS 7 & 7.5 which depends on how familiar you are with IIS 5.1 you may have to do some extra steps.

  1. First open INETMGR Start -> Run -> type INETMGR <enter>
  2. Expand the (local computer) -> expand (Web Sites) -> Expand (Default Web Site)
  3. Select the bugnet folder and right click -> Properties
  4. On the Directory tab hit the <Create> button (leave all defaults)
  5. On the Documents tab
    1. Click Add
    2. Enter Default.aspx -> Ok
    3. Using the left arrow-up button move it into the first position
  6. Ignore the Directory Security tab
  7. Ignore the HTTP Headers tab
  8. On the ASP.NET tab Select the ASP.NET Version 4.0.xxxxx
  9. Press Ok

Now try hitting the install/install.aspx fiel again, if you have configured the connection string correctly in the web config it should start installing.

If you do not see the 4.0.xxxxx in the dropdown on the ASP.NET tab then you need to install ASP.NET 4.0.  However if you have to install it then you wil need to register .NET 4.0 with IIS using the command line tool aspnet_regiis.exe

Open up a cmd prompt (Start -> Run -> type cmd <enter>) and type "C:\WINDOWS\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis.exe" -i <enter>

FYI: The instructions above are for using forms authentication not windows integrated auth.

Hope this helps some.

Jun 1, 2012 at 11:45 PM

Hi,

I am sorry for a late reply. I will be publishing my steps by Monday to make sure that I am following the correct steps.. I even tried installing the app on Windows server 2008/ IIS7 but agian failed.